Krack WPA2 Güvenlik Açığı İçin Ürün Güncellemeleri Listesi

Güncelleme: 20/10/17 14:35 EST

Krack adı verilen, saldırganların WPA2 kablosuz ağ iletişim protokolüne saldırarak; bağlantıları dinlemesine, kötü amaçlı yazılım yüklemesine ve web sayfalarını değiştirmek için kablosuz ağa veri eklemesinine izin verebilecek büyük bir güvenlik açığı bugün duyuruldu. (Ne olduğuna daha önceki yazımda değindim.)

Birçok WiFi ürün üreticisi, güncellenmiş firmware yazılımı ve sürücülerini yayınlıyorlar. Kullanıcıların kendilerini korumak için bir güncelleme hazır olduğunda bu donanım güncellemesini kesinlikle yapması öneriliyorlar. Bu güncellemelere router firmware ve kablosuz ağ kartı sürücüleri de dahildir.

Bu amaçla kullanıcılara yardımcı olmak için çeşitli WiFi üreticileriyle ilgili bilinen bilgilerin yer aldığı bir liste hazırladım ve yeni sürücülerin olup olmadığını kontrol ettim. Bu güvenlik açığı oldukça yeni olduğundan, şu anda az bilgi var, önümüzdeki günlerde bu sayfayı kontrol ederek yeni bilgilerin mevcut olup olmadığını kontrol etmenizi öneririm. Bu sayfa, üreticilerin irtibat kurmasından kaynaklanan bilgileri, CERT’in bilgilendirici sayfasını ve diğer kaynakları içermektedir.

Konu ile ilgili bilgi bulunan şirketler:

ADTRAN
Forumlarında yazdıkları bir bir yazıda; bu konuda şu anda soruşturma yaptıklarını ve foruma kayıt yaptıran tüm kullanıcılara konu ile ilgili ayrıntılı bir güvenlik uyarısı gönderdiklerini bildirdi.

Aerohive Networks
Aerohive, hangi şartlar altında ürünlerinin Krack’e karşı savunmasız olduğunu açıklayan bir açıklama yayınladı.

Arch Linux
Arch, wpa_supplicant ve hostapd için güncellemeleri yayınladı.

Amazon
Bir Amazon Sözcüsü konu ile ilgili olarak “Cihazlarımızdan hangisinin bu güvenlik açığı içerediğiyle ilgili inceleme sürecindeyiz ve ihtiyaç duyulduğunda yamalar çıkartacağız.” dedi.

Apple
Krack için yapılan düzeltmeler iOS, tvOS, watchOS ve macOS beta sürümlerinde mevcuttur. Aşağıdaki tweet’e göre bir sonraki yazılımda yayınlanacak:

Aruba Networks
Yama bilgilerine bu sayfadan erişilebilirsiniz. Ayrıca bir de SSS yayınlandı.

Belkin, Linksys, ve Wemo
Belkin yaptığı açıklamada; “Belkin Linksys ve Wemo, WPA güvenlik açığının farkındalar. Güvenlik ekiplerimiz ayrıntıları doğruluyor ve buna göre ileride açıklama yapacağız. “dedi.

Cisco
Cisco, ürünleri ve güvenlik açığı bulunan ürünlerin bir listesine ilişkin bir açıklama yayınladı. Cisco, IOS ve sürücü güncellemelerinin geliştirildiğini ve yakında yayınlanacağını bildirdi. Cisco ürün kullanıcılarının gelecekteki güncellemeler için sık sık açıklama sayfasını kontrol etmelerini öneriyor.

DD-WRT
Krack için bir DD-WRT SVN‘de bir yama yayınlandı. Halihazırda yamalı bir firmware’in indirilmeye hazır olup olmadığı bilinmiyor.

Debian
Debian, Debian Security Announce posta listesine, Krack güvenlik açığının giderildiği hakkında bir açıklama yazısı gönderdi.

Dell
Bir Dell sözcüsün yapmış olduğu açıklamaya göre Krack güvenlik açığının araştırıldığını ve önümüzdeki günlerde bir konuda açıklama yapılacaklarını söyledi.

D-Link
D-Link, yonga seti üreticilerinden yamaları beklediklerini belirten bir açıklama yayınladı. Ayrıca, “Tüketici kullanıcıları için önceliğiniz, dizüstü bilgisayarlar ve akıllı telefonlar gibi D-Llink cihazları güncelleştirmeliler” şeklinde yazılı açıklamada bulundular.

DrayTek
DrayTek, hangi ürünlerin Krack’den etkilenip, hangilerinin etkilenmediğini ayrıntılarıyla bir açıklayan bir yazı yayınladı ve önümüzdeki hafta güncelleme yapılacağını söyledi.

eero
eero web sayfasında, Krack saldırılarını engelleyen eeroOS 3.5 sürümünü yayınladıklarını açıklayan bir yazı yayınladı.

EnGenius
EnGenius sözcüsü, etkilenen aygıtlar için bir düzeltme eki yayınlanma takvimi içerecek bildirinin Cuma günü yapacakları bir açıklamada yayınlayacaklarını söyledi.

Espressif
Espressif, Github sayfasında ESP-IDF, ESP8266 RTOS SDK ve ESP8266 NONOS SDK güncellemelerini yayımladı.

Fedora
Fedora, Fedora 25 için bir test güncellemesi yayınladı. Fedora 26 ve Fedora 27 sürümleri için güncelleme yazılımları yayınlanmıştır.

FreeBSD
CERT’ye göre FreeBSD bu güvenlik açığının farkındadır ve kullanıcılar FreeBSD-Announce posta listesine üye olmalı veya Güvenlik Bilgileri sayfalarını izlemelidir.

Fortinet
Fortinet; FortiAP 5.6.1 sürümü ile Krack açıklarını düzelttini belirten açıklama yayınladı.

Google
Android 6.0 ve sonraki sürümleri şu anda bu saldırıdan etkileniyor. Google’ın açıklaması “Bu sorunun farkındayız ve önümüzdeki haftalarda etkilenen tüm cihazlara yamalıyor olacağız.” Google WiFi ile ilgili henüz bir bilgi yok.

Intel
Intel, güncellenmiş sürücülere bağlantılar içeren bir açıklama yayınladı.

Kisslink
Kisslink, ürünlerinin Promximity teknolojisi ile korunduğunu ve böylelikle WPA2’yi kullanmamaları sebebi ile bundan doğan hatalarından etkilenmediklerini açıkladı.

Lede
Lede, “Test tamamlandıktan hemen sonra bir güncelleme LEDE 17.1.4 ile çıkacak” dedi. OpenWRT ile ilgili henüz bir bilgi yok.

LineageOS
LineageOS, Krack açıklarını önlemek için yamalar yayınladı.

Linux
Güvenlik açığına göre, “Saldırı, özellikle Linux’ta yaygın olarak kullanılan Wi-Fi istemcisi olan wpa_supplicant’ın 2.4 ve üstü sürümlerine karşı büyük bir felakettir.” Yamalar buradan indirilebilir.

Meraki
Krack güvenlik açığı sorunlarını çözen Cisco Meraki için güncellemeler yayınlandı. Danışma belgesinde daha fazla bilgi bulunabilir: 802.11r Güvenlik Açığı (CVE: 2017-13082) SSS.

Microchip Technology
Microchip mevcut güncellemeleri içeren bir açıklama yayınladı.

Microsoft
Microsoft, 10 Ekim Salı günü yayınlamış olduğu güncelleme ile Krack güvenlik açığını düzeltmiştir.

MikroTik
MikroTik’e göre: “RouterOS v6.39.3, v6.40.4, v6.41rc etkilenmemektedir! AP modu cihazlar etkilenmemektedir.” Ayrıca, bu güvenlik açığından etkilenen cihazları için geçtiğimiz hafta yeni bir yazılım sürümleri çıkarttıklarını söylediler.

Netgear
Netgear, Krack’ten etkilenen ürünlerin listesini içeren bir açıklama yayınladı.

Nest
Twitter’da yaptığı açıklamada; önümüzdeki hafta yamaların çıkarılacağını, cihazların otomatik olarak güncelleneceğini ve kullanıcı müdahalesi gerekmediğini söyledi.

OpenBSD
OpenBSD, bu güvenlik açığını düzeltmek için yama yayınlamıştır. Daha fazla bilgi buradan okunabilir.

Open-Mesh & CloudTrax
Open-Mesh & CloudTrax, Krack güvenlik açıklığı ile ilgili bir açıklama yayınlandı. 17 Ekim sonuna kadar otomatik güncellemeleri kullananlara bir güncelleştirme yapması bekleniyor.

Peplink
Peplink, Wi-Fi kullanıcılarının WAN işlevselliği olarak bu saldırıya karşı savunmasız olduğunu belirten bir açıklama yayınladı. Açıklamada ‘Bu sorunu geçici olarak çözmek için kullanıcılar bu özelliği devre dışı bırakabilir ve güncellenmiş bir yazılımın gelmesini bekleyebilirler’ söyledi.

pfSense
FreeBSD tabanlı pfSense, FreeBSD’nin sorunu düzeltmesi için forumunda destek talebi açtı.

Qualcomm
Qualcomm sözcüsü yaptığı açıklamada şunları söyledi: “Güvenliği ve gizliliği destekleyen teknolojilerin sağlanması Qualcomm Technologies, Inc. (QTI) için bir önceliğe sahip. Qualcomm tarafından desteklenen WPA paket numarasının yeniden kullanımını içeren açık kaynak güvenlik sorununun tüm uygulamalarını belirlemek ve bunları ele almak için endüstri ortaklarıyla birlikte çalışmaktayız. Bu sorunlara yönelik yamalar artık Kod Aurora Forumu’nda ve diğer dağıtım kanallarında mevcuttur; bunlar, kalite güvencesi sürecimizden geçtikten sonra yayınlanacaktır.”

Red Hat
Red Hat, wpa_supplicant’ın güvenlik açığıyla ilgili bir açıklama yayınladı. Yazılım güncellemesi hakkında henüz bir bilgi yok.

Raspberry Pi
Paket olarak wpa_supplicant‘ı kullandığından, paketleri güncellemeniz gerekiyor. Yamalı bir wpa_supplicant’ı yüklemek için sudo apt update‘i ve ardından sudo apt upgrade‘i kullanmanız yeterlidir.

Ruckus Wireless
Ruckus Wireless, 802.11r’yi devre dışı bırakmanın CVE-2017-13082’yi hafifleteceğini bildiren bir güvenlik önerisi yayınladı. Etkilenen cihazlar için güvenlik yamaları kullanıma hazır olur olmaz piyasaya sürülecektir.

Sierra Wireless
Sierra Wireless, etkilenen ürünler ve iyileştirme planları hakkında teknik bir bülten gönderdi.

Sonicwall
Sonicwall, saldırıdan etkilenmediklerini  bildiren bir açıklama yayınladı.

Sophos
Sophos, Sophos UTM Wireless, Sophos Firewall Wireless, Sophos Central Wireless ve Cyberoam Wireless ürünlerinin Krack güvenlik açığından etkilendiğini belirten bir açıklama yayınladı. Bu ürünler için güncellemeler yakında çıkacak.

Synology
Synology, WiFi dongle’lı Synology DiskStation Manager (DSM) ve Synology Router Manager (SRM) Krake’ye karşı korumasız olduğunu bildiren bir açıklama yayınladı. Etkilenen ürünler için güncellemeler yakında çıkacak.

Tanaza
Tanaza, v2.15.2 firmware’inin Krack için bir yama paketi içerdiğini bildirdi.

Toshiba
CERT’ye göre, Toshiba’nın Wireless Lan Adaptörlü SureMark 4610 Yazıcı modelleri ( 1NR, 2CR, 2NR) ve Canvio AeroMobile Kablosuz SSD ürünü etkileniyor. Toshiba, yazıcıyla ilgili olarak ürün sahipleri ve iş ortakları ile doğrudan temas kuracak ve kablosuz SSD kartı için bir firmware güncellemesi yayınlanacak.

TP-Link
TP-Link teknik desteğiyle görüştüğümüzde “Üst düzey yetkililerimizin bu konu hakkında bilgileri var. Şu anda, TP-Link ürününün bundan etkilendiğine dair herhangi bir bilgi almadık. Herhangi bir yeni bilgi aldıktan sonra resmi web sitemizde bir güncelleme yayınlayacağız.” dedi.

Turris Omnia
OpenWRT kullanan Turris, forumlarında depolarına bir düzeltme ekleyerek bir düzeltmeyi test edip çözeceklerini yazdı. Bu yazıya göre, bu OpenWRT’nin yakında bir güncelleme yayınlaması bekleniyor.

Ubiquiti (UniFi, AmpliFi, airMax)
Ubiquiti, UniFi, AmpliFi ve airMax ürünlerinin Krack güvenlik açığından etkilendiğini bildiren ayrıntılı bir açıklama yayınladı. Açıklamada, bu saldırıyı etkisizleştiren güncelleştirme bağlantıları da yer almaktadır.

802.11r (Fast Roaming) beta özelliğinin hala savunmasız olduğu ve sorun çözülene kadar devre dışı bırakılması gerektiği öneriliyor.

Ubuntu
Ubuntu, bu güvenlik açığını gidermek için wpa_supplicant ve hostapd‘ın nasıl güncelleneceğini içeren bir açıklama yayınladı.

WatchGuard
WatchGuard, güncellemelerinin çeşitli ürün ve hizmetleri için ne zaman hazırlanacağını anlatan bir açıklama yayınladı.

WiFi Alliance Duyurusu
WiFi Alliance KRACK güvenlik açığı ile ilgili bir açıklama yaptı.

Zyxel
Zyxel, hangi ürünlerin etkilendiğini ayrıntılarıyla anlatan bir sayfa hazırladı. Güvenlik açığını gidermek için çalışmaya devam ediyor ve henüz güncellenmiş bir sürücü ve firmware bulunmamaktadır.

Krack’tan etkilenmediğini açıklayan şirketler:

Arista Networks, Inc.
Lenovo
Vmware

Henüz bilgi bulunmayan şirketler:

Juniper Networks
3com Inc
Actiontec
Alcatel-Lucent
AsusTek Computer Inc.
Atheros Communications, Inc.
Barracuda Networks
Broadcom
CentOS
Edimax
EMC Corporation
Extreme Networks
F5 Networks, Inc.
Foundry Brocade
Hewlett Packard Enterprise
IBM, INC.
Kyocera Communications
Marvell Semiconductor
MediaTek

One thought on “Krack WPA2 Güvenlik Açığı İçin Ürün Güncellemeleri Listesi

  1. Pingback: Yeni Krack Saldırısı, WPA2 WiFi Protokolünü Kırıyor | Baris Kayadelen .deb

Comments are closed.